[Better solution!] TP-Link offers way to add local API back


Update Nov 26: TP-Link has now announced that they are working on a new firmware that should solve it. DM them on Twitter for info.


Last week TP-Link released an update for their HS100 and HS110 plugs that removed the local API. This was done because of a “security concern”. I put this in quotes because it has not been verified and this reason has been given before when removing interoperability. TP-Link communicated this via Twitter in response to a user voicing their concern.

Lots of users, rightfully so, got angry. They bought the plugs assuming the local API was a feature. Removing this feature and forcing users through the TP-Link cloud sucks. It removes the one feature why TP-Link stood out among many smart plugs.

After a week of angry users, it looks like TP-Link has listened… somewhat. They are offering a temporary solution to roll back the firmware. We haven’t found any public documentation, but there are forum posts by their employees here and here about it.

TP-Link employee on the forums explaining how to downgrade the firmwareForum post by a TP-Link employee to send in a ticket.

We are hoping for a better solution, but for now this is what you should do:

  1. Submit a ticket to technical support. Make sure to include the MAC address of your plug. We got an update from TP-Link that this step is no longer necessary.
  2. Go to the forums and send this user a message with your TP-Link ID, model number, hardware version and MAC address.

TP-Link, if you’re reading along, please reach out to us at [email protected] so we can discuss a better long term solution for local control. Happy to talk!





Source link

We will be happy to hear your thoughts

Leave a reply

truvallu.com
Enable registration in settings - general